Sunday, May 07, 2006

Motherboard Woes

Recenty I added a second Opteron CPU and 2Gb more RAM to my Tyan Thunder motherboard, bringing the total to 4Gb.

Windows however, decided that it would only detect 2,75Gb. While booting, the BIOS nicely displayed 4Gb. What the...?

Booting with Linux live CD: same problem.

Searching a lot with Google: 'memory hole' setting in the 'hammer configuration'. A lot of people are having this problem and proposing various solutions.

What worked for me: (1) flash motherboard to latest version, finding a working Win98 boot disk was a real pain. (2) If your CPU has a stepping 'Cx' ('x' standing for any letter), put 'memory hole' option in BIOS on 'software', otherwise, put it on 'hardware'.

After booting Windows XP Professional: same problem. Trying with an Ubuntu 64 bit live CD... it works! (3) Installing Windows x64. Now it works in Windows too.

So main problem was a 32 bit OS. Bottom line: if you have a 64bit CPU, do not bother to install a 32 bit OS anymore (like I did), even if the emulation is perfect etcetera...

I hope my experience was useful to anyone (I had a much nicer post written out, but due to Internet Explorer popup blocker while spell-checking, I've lost it. Firefox' blocker is much better, it doesn't automatically reloads the page after allowing popups, but silently waits until you try again.)

P.S.: indeed, my Windows x64 came with pre-baked SP2... Damn. Patching TCP half-open connection limit, completely disabling security center. Stupid new Internet Explorer settings... I hate SP2.
I also had to but the 'MAC LAN Bridge' options to 'Enable' in the BIOS for the Windows drivers to detect my ethernet controllers. I had not to do this in Windows XP (32 bit).

Technorati Tags: , , , .

No comments :

Post a Comment